CentOS8でsambaをコンパイルするのに必要となるパッケージ
https://wiki.samba.org/index.php/Package_Dependencies_Required_to_Build_Samba

追加レポジトリとしてepelが必要

[root@c ~]# yum install epel-release

その後に、下記を実行します。

レポジトリのPowerToolsはデフォで入ってます

[root@c ~]# yum --enablerepo=PowerTools,epel install docbook-style-xsl gcc gdb gnutls-devel gpgme-devel jansson-devel \
               keyutils-libs-devel krb5-workstation libacl-devel libaio-devel libarchive-devel libattr-devel \
               libblkid-devel libtasn1 libtasn1-tools libxml2-devel libxslt lmdb-devel openldap-devel pam-devel perl \
               perl-ExtUtils-MakeMaker perl-Parse-Yapp popt-devel python3-cryptography python3-dns python3-gpg \
               python36-devel readline-devel rpcgen systemd-devel tar zlib-devel
 
(でも追加で下記が必要でした)
libtirpc-devel

トップ   編集 添付 複製 名前変更     ヘルプ   最終更新のRSS
Last-modified: 2019-10-14 (月) 04:15:44 (298d)